opkg update
opkg install luci
/etc/init.d/uhttpd enable
/etc/init.d/uhttpd start
在浏览器访问路由器的网关地址即可看到luci界面了,就可以在浏览器直观的配置路由器了。为了配置多ssid,我们可以在openwrt上开启vlan来模拟多个虚拟子网如vlan1和vlan2
config switch eth1
option reset 1
option enable_vlan 1
config switch_vlan
option vlan 1
option device eth1
option ports '0 1 2 5t'
config switch_vlan
option vlan 2
option device eth1
option ports '3 5t'
两个vlan网络接口分别为eth1.0和eth1.1,0、1、2口为一个子网,3口单独一个子网。现在把eth1.0和eth1.1两个网络接口组成一个网桥lan:
config interface lan
option type bridge
option ifname 'eth1.0 eth1.1'
option proto none
lan默认不设置ip,如果想远程访问OpenWrt,则必须按情况设置static或dhcp。
关闭防火墙,因为网桥用不着:
/etc/init.d/firewall disable
重启网络后可以用ifconfig看到很多网络接口,只要监听br-lan就行了:
br-lan Link encap:Ethernet HWaddr ××××××××××××××××××
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
eth1 Link encap:Ethernet HWaddr \*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\**
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:14
eth1.0 Link encap:Ethernet HWaddr \*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\*
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
eth1.1 Link encap:Ethernet HWaddr \*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\\*\*\*|\*
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
在OpenWrt里安装Tcpdump:
opkg install tcpdump
运行Tcpdump监听POP邮箱密码:
tcpdump -X -i br-lan port 110
/udisk/tcpdump -XvvennSs 0 -i br-lan tcp[20:2]=0x4745 or tcp[20:2]=0x4854 -w ./udisk/test.cap
将结果dump到本地,0x4745 为"GET"前两个字母"GE",0x4854 为"HTTP"前两个字母"HT"。
注意:tcpdump 对截获的数据并没有进行彻底解码,数据包内的大部分内容是使用十六进制的形式直接打印输出的。显然这不利于分析网络故障,通常的解决办法是先使用带-w参数的tcpdump 截获数据并保存到文件中,然后再使用其他程序(如Wireshark)进行解码分析。当然也应该定义过滤规则,以避免捕获的数据包填满整个硬盘。
下图是test.cap在wireshark中的展现。
可以看到所有报文例如http协议的内容可以很方便的查看到。如果你的通信报文没加ssl的话,配置下你的tcpdump,应该能捕获到很多密码明文了:)